Linux Mint установка драйвера

8 января 2016 - Олег
Linux Mint установка драйвера

Когда вы скачали Linux Mint и установили его на компьютер, то у вас возникает вопрос о том, какие нужно устанавливать драйвера и как это сделать. Данная инструкция ориентированна на начинающих пользователей, поэтому мы постараемся разобрать данный вопрос наиболее подробно.

Когда вы производили установку Linux Mint, у вас автоматически установилось большинство драйверов. Исключением является драйвер видеокарты, принтера и другого специфического оборудования. Если вы настраиваете свой компьютер, то вы хорошо знаете модели вашего оборудования, но что делать, если вы в гостях или купили компьютер с рук? В подобных случаях нам поможет аналог программы Aida для Linux Mint. Название этой утилиты — SysInfo и вы можете скачать ее с нашего сайта. Распакуйте архив, зайдите в папку sysinfo и кликните правой кнопкой мыши по файлу sysinfo. В меню выберите "свойства" и перейдите во вкладку "права". Установите галочку "позволять выполнение файла как программы" и нажмите "ок". Теперь запустите ее двойным нажатием левой кнопки мыши.

Вы может увидеть здесь всю необходимую информацию о вашем железе и вопросов стало намного меньше.

Linux Mint установка видео драйвера Nvidia

Владельцы видеокарт компании Nvidia могут установить драйвер достаточно просто. Перейдите в меню-администрирование-менеджер драйверов (это необходимо делать с подключенным интернетом).

Перед вами откроется окно, в котором вам нужно выбрать рекомендуемый драйвер с названием nvidia. После этого, нажмите "применить изменения" (Apply Changes), дождитесь окончания установки и перезагрузите ваш компьютер.

Linux Mint установка видео драйвера Ati (AMD)

Владельцы видеокарт Ati (AMD) перейти в меню-администрирование-менеджер драйверов (это необходимо делать с подключенным интернетом).

Найдите строку с названием fglrx и установите соотвествующую галочку. После этого, нажмите "применить изменения" (Apply Changes), дождитесь окончания установки и перезагрузите ваш компьютер.

Помимо этого способа, вы можете установить драйвер из терминала следующими командами:

sudo apt-get install fglrx

sudo aticonfig --initial

Linux Mint установка видео драйвера Intel

Если у вас на ноутбуке или компьютере используется видеокарта Intel, то вам необходимо перейти на страницу загрузки драйвера. Найдите строку "Intel Graphics Installer for Linux*" и скачайте установщик. Он будет в виде deb файла, который можно легко установить двойным кликом.

Можно воспользоваться более простым способом и просто добавить репозиторий. Откройте терминал и введите команды

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt-get update

sudo apt-get dist-upgrade

Теперь у вас самая последняя версия драйвера и просто перезагрузите компьютер.

Linux Mint установка драйвера принтера

Подключите ваш принтер к компьютеру и включите его. Перейдите в меню-центр управления и найдите там раздел оборудование.

Нажмите на кнопку Printers и перед вами появится вот такое окно:

Нажмите на кнопку "добавить" и вы увидите название вашего принтера в списке

Нажмите кнопку "вперед" и программа начнет поиск драйвера. В следующем окне выберите производителя принтера и нажмите "вперед".

Если вашей модели не будет в списке производителя, то проверьте его наличие на официальном сайте.

Обладатели принтеров Canon могут добавить репозиторий с помощью команды в терминале:

sudo add-apt-repository ppa:michael-gruz/canon-trunk

sudo apt-get update

sudo apt-get install cnijfilter-ip100series

В последней команде вам нужно заменить ip100series на вашу модель.

Как видите, ничего сложного нет, но если у вас остались вопросы, то задавайте их на нашем форуме и мы постараемся помочь вам.

Комментарии (11)
Kvanterman # 21 сентября 2016 в 05:10 0
А как быть с неустановленными дровами на сетевые карты? если попросту НЕТ сети..
как быть?
Олег # 21 сентября 2016 в 09:08 0
Пробовать более старые версии системы, просто поддержка вашего железа закончилась
kasius # 25 ноября 2016 в 00:11 0
Здравствуйте, у меня Canon laser shot LBP 1120. вводил, вводил а оно все равно пишет
"Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет cnijfilter-1120series. (вводил имя по разному от полного до просто цифр).
прошу помогите.
theSectClown # 4 декабря 2016 в 15:14 0
Все конечно классно расписано. Но что делать, если менеджер драйверов выглядит так
Олег # 4 декабря 2016 в 18:55 0
Это значит, что в 18 версии нет проприетарных драйверов ATI/AMD. Либо довольствуйтесь открытыми, либо устанавливайте 17.1
theSectClown # 4 декабря 2016 в 19:18 0
Хоть бы слово в статье было по этому поводу. Я весь гугл перерыл, сутки искал и ни черта не нашёл. Где брать открытые драйверы. Подключил какие-то репозитории кучи и толку ноль. Решил блин перейти с глючной винды называется.
Олег # 4 декабря 2016 в 21:03 0
Открытые уже у вас работают, иначе бы вы изображения на экране не видели бы.
dmitriilast # 5 декабря 2016 в 20:20 0
Значит нет ПОКА? или вообще нет и не будет?
и почему от 17й нельзя подключить?
igorvsk # 27 декабря 2016 в 16:34 0
А почему у АМД выбирать не рекомендуемый? Глюки? Игры работать будут? Извините, я только собираюсь перейти с винды на Линукс, вот собираю инфу.
igorvsk # 27 декабря 2016 в 21:14 0
офигенная помощь)) Пойду дальше))
Pimen6 # 5 января 2017 в 15:40 0
Помогите! Не могу установить Brother HL-2140R на mint18.1

Голосования

Какое рабочее окружение Вы предпочитаете?